Search found 55 matches

by Arek
Mon 2018-11-26 14:44
Forum: VS1010 Forum
Topic: How to set pins to SD card low or to input?
Replies: 1
Views: 552

Re: How to set pins to SD card low or to input?

Found solution! No action necessery.
Thanks
by Arek
Mon 2018-11-26 13:47
Forum: VS1010 Forum
Topic: How to set pins to SD card low or to input?
Replies: 1
Views: 552

How to set pins to SD card low or to input?

Hi, how can I set the VS1010 sd card connections to low (or preferably to inputs / tristate) via the serial GPIO. If this is not possible then how can i do it programmed from SPI memory? The reason is the use of the S8 SD card controller, which requires programming. The programming uses the SD conne...
by Arek
Thu 2018-10-25 10:49
Forum: VS1010 Forum
Topic: ReplayGain support in VS1010D
Replies: 0
Views: 390

ReplayGain support in VS1010D

Hi,

Q. is ReplayGain supported in VS1010D?
If yes, pls a few hints how to use it.

thanks and best regards

am
by Arek
Wed 2018-10-24 16:46
Forum: VS1010 Forum
Topic: VS1010D sometimes does not see SPI memory.
Replies: 5
Views: 301

Re: VS1010D sometimes does not see SPI memory.

Yes, thank you.

Arek
by Arek
Tue 2018-10-23 17:27
Forum: VS1010 Forum
Topic: VS1010D sometimes does not see SPI memory.
Replies: 5
Views: 301

Re: VS1010D sometimes does not see SPI memory.

Hi,

With 100k pull up/pull down works well.

Thx
by Arek
Mon 2018-10-22 21:24
Forum: VS1010 Forum
Topic: VS1010D sometimes does not see SPI memory.
Replies: 5
Views: 301

Re: VS1010D sometimes does not see SPI memory.

Hi Panu,

I have my own board.
Runlevel 7 because my program is in SPI memory placed.

Good idea is to check/change the resistors. Thank you
by Arek
Mon 2018-10-22 19:37
Forum: VS1010 Forum
Topic: VS1010D sometimes does not see SPI memory.
Replies: 5
Views: 301

VS1010D sometimes does not see SPI memory.

Hi A new problem. Configuration: my program is placed on SPI, Soundtracs on SD. After switching on, sometimes VS does not see SPI memory and starts in auto-play mode. Does anyone know the reason for such behavior? Typical start: C#0d1d VS1010D VSOS 4.20 Files:6. Buffers:3. Runlevel 7 SPIF:c214, 2048...
by Arek
Tue 2018-10-09 11:29
Forum: VS1010 Forum
Topic: Click after power on
Replies: 1
Views: 153

Click after power on

Hi, Immediately after switching on, I hear two clicks. Start_VS_AudioOutput_ProgStart.png Above picture is taken from my scope: yellow: Audio (L+R), green shows when my programm start. Software: At the beginning, after I/O definitions follow: setVolume(50); // practically nothing to hear AmpDemute()...
by Arek
Thu 2018-09-13 16:04
Forum: VS1010 Forum
Topic: GPIO0_0 (PWM)
Replies: 4
Views: 286

Re: GPIO0_0 (PWM)

Hi, many thanks.

I have to redesign my PCB (a few other changes) so I can switch to GPIO2_5 (works!) and... this case is closed.
by Arek
Thu 2018-09-13 14:41
Forum: VS1010 Forum
Topic: GPIO0_0 (PWM)
Replies: 4
Views: 286

Re: GPIO0_0 (PWM)

Thank you Hannu,

The question is if GPIO0_0 (second function: PWM) need something more.
I don't have any problems to set or clear
GPIO2_6, GPIO2_7, GPIO0_7
Only GPIO0_0 (which has a secondary function) make trouble.