Search found 25 matches

by YuryShatz
Wed 2018-10-17 15:33
Forum: VS1005 and VSOS Software
Topic: No sound on VS1005 custom board
Replies: 13
Views: 2168

Re: No sound on VS1005 custom board

Thanks Pasi!
by YuryShatz
Tue 2018-10-16 9:54
Forum: VS1005 and VSOS Software
Topic: No sound on VS1005 custom board
Replies: 13
Views: 2168

Re: No sound on VS1005 custom board

Pasi and Panu Thank you for your help. It seems that we have more than one defect on our boards which makes it confusing. We are going to manufacture the next series, now we are trying to correct as many errors as we can. 1) One board is (or was) almost ok, but did not sound due to short circuit. 2)...
by YuryShatz
Sun 2018-09-09 17:13
Forum: VS1005 and VSOS Software
Topic: No sound on VS1005 custom board
Replies: 13
Views: 2168

No sound on VS1005 custom board

Hello Panu I guess this is similar to this thread http://www.vsdsp-forum.com/phpbb/viewtopic.php?f=15&t=2292 We are trying to run our custom board. Our program starts the decoder, it is decoding (or doing something) for the expected amount of time, and ends successfully saying "Decoder returns 0, 'o...
by YuryShatz
Fri 2018-03-16 23:43
Forum: VS1005 and VSOS Software
Topic: Command line for prommer
Replies: 9
Views: 1841

Re: Command line for prommer

Hannu, thank you once again I loaded vs3emuc and it works like a charm, both from VSIDE and from command line. From command line it's more reliable at 57600. For those with the same question, command line for internal flash goes like this: "C:\Program Files (x86)\VSIDE\bin\vs3emu" -p 6 -chip vs1005 ...
by YuryShatz
Thu 2018-03-15 9:06
Forum: VS1005 and VSOS Software
Topic: Command line for prommer
Replies: 9
Views: 1841

Re: Command line for prommer

Oh, thank you Hannu!

I did not realize you could only do that with shell loaded. I tried it with my program and with no program at all.
by YuryShatz
Wed 2018-03-14 23:45
Forum: VS1005 and VSOS Software
Topic: Command line for prommer
Replies: 9
Views: 1841

Command line for prommer

To upgrade kernel or make my custom modifications to it, I use prommer utility in VSIDE. - It usually worked, sometimes not the first time - Now it usually says "unable to auto-detect". - When it does not, often it hangs. Gives a message "Programming the memory! See the stdin/stdout console for deta...
by YuryShatz
Sat 2018-03-10 12:03
Forum: VS1005 and VSOS Software
Topic: Kernel 3.22 error when compiling
Replies: 2
Views: 1079

Re: Kernel 3.22 error when compiling

The problem is still there with kernel 3.54 and VSIDE 2.43
by YuryShatz
Tue 2018-02-06 0:32
Forum: VS1005 and VSOS Software
Topic: INITNAND gets stuck
Replies: 6
Views: 1053

Re: INITNAND gets stuck

(deleted, solved another problem myself) Dear Panu Sorry about bothering you with the problems I can solve myself. Recap in case someone else is wondering: After successfully running InitNAND you need to format NAND. The solution is here: http://www.vsdsp-forum.com/phpbb/viewtopic.php?f=13&t=1664&p=...
by YuryShatz
Mon 2018-02-05 23:09
Forum: VS1005 and VSOS Software
Topic: INITNAND gets stuck
Replies: 6
Views: 1053

Re: INITNAND gets stuck

For anyone reading this:

Removed my program and all the drivers, rebooted. InitNAND works like a charm.

It may or may not be obvious.
by YuryShatz
Mon 2018-02-05 22:41
Forum: VS1005 and VSOS Software
Topic: INITNAND gets stuck
Replies: 6
Views: 1053

Re: INITNAND gets stuck

(removed. Solution found!)