Search found 7 matches

by vtech
Tue 2020-03-24 16:50
Forum: Stand-Alone Applications
Topic: VS1063 MP3 File not playing correctly
Replies: 7
Views: 290

Re: VS1063 MP3 File not playing correctly

Throughout the read from USB, I am printing the values and they are consistently as follows :

CLOCKF : B430
MODE : 820
STATUS : 60
AUDATA : AC44
by vtech
Thu 2020-03-19 19:17
Forum: Stand-Alone Applications
Topic: VS1063 MP3 File not playing correctly
Replies: 7
Views: 290

Re: VS1063 MP3 File not playing correctly

I am using a USB stick as storage. It is definitely able to transfer fast enough. It is transferring at USB 1.0 speed currently and it tested at 11.7Mb/s which is more than adequate, right ?
by vtech
Thu 2020-03-19 15:37
Forum: Stand-Alone Applications
Topic: VS1063 MP3 File not playing correctly
Replies: 7
Views: 290

Re: VS1063 MP3 File not playing correctly

The file has a bitrate of 121kbps. I am sending data appropriately respecting dreq and xDCS. I dropped the bitrate down to 96kbps and the choppiness is gone and the audio plays fine, so it seems the chip is being starved. I didn't change the line from the code to change the clock rate : WriteSci(SCI...
by vtech
Wed 2020-03-18 23:46
Forum: Stand-Alone Applications
Topic: VS1063 MP3 File not playing correctly
Replies: 7
Views: 290

Re: VS1063 MP3 File not playing correctly

Ok, I have some more info. It appears that the fread() is stopping prematurely due to a library issue on my side. However, now the MP3 file is playing and it is missing data during playing as indicated by gaps shown on my o-scope. In addition, the audio sounds robotic. My understanding was that the ...
by vtech
Wed 2020-03-18 19:24
Forum: Stand-Alone Applications
Topic: VS1063 MP3 File not playing correctly
Replies: 7
Views: 290

VS1063 MP3 File not playing correctly

I am struggling with getting a simple MP3 file to play using the player1063.c file. I successfully performed a software and hardware init and loaded the latest plugin. I am running on a PocketBeagle and have mounted a USB drive that contains the MP3 file that I am playing. I am feeding the bytes by ...
by vtech
Mon 2020-02-24 19:02
Forum: Slave Decoder Applications
Topic: PocketBeagle driving VS1063
Replies: 2
Views: 684

Re: PocketBeagle driving VS1063

As a follow up, I successfully got it working. I was using the CS from from the PocketBeagle associated with the SPI interface, but instead chose a separate GPIO to perform the CS when DREQ went HIGH. After I did that it all just worked. As a side note, the PocketBeagle doesn't allow for a SPI_NO_CS...
by vtech
Sun 2020-02-23 9:33
Forum: Slave Decoder Applications
Topic: PocketBeagle driving VS1063
Replies: 2
Views: 684

PocketBeagle driving VS1063

Hello all, This is my first time posting, so please bear with me as i'm just diving into some uncharted waters. I have a PocketBeagle connected to an Adafruit Audio Breakout (https://www.adafruit.com/product/1381). I had a manufacturing facility replace the stock VS1053 with a VS1063 because I need ...