Search found 11 matches

by FelixKunzJr
Tue 2020-07-07 14:17
Forum: VS1005 and VSOS Software
Topic: SD Ident / Card stuck. Chip gets hot as hell.
Replies: 2
Views: 976

SD Ident / Card stuck. Chip gets hot as hell.

Hi, I've managed to get my first board running (VS1005GF). Now i wanted to make a second one (same design, same everything) and soldered it together. After a few attempts i got the software up and running. But somehow when i load the SD driver i get following message: "E'SD Ident / Card stuck". I've...
by FelixKunzJr
Wed 2020-06-10 12:14
Forum: VS1005 and VSOS Software
Topic: USB Mass Storage Device doesn't work.
Replies: 16
Views: 2362

Re: USB Mass Storage Device doesn't work.

Yes, IOVDD is steady at 3.1-3.3V.
by FelixKunzJr
Mon 2020-06-08 14:28
Forum: VS1005 and VSOS Software
Topic: USB Mass Storage Device doesn't work.
Replies: 16
Views: 2362

Re: USB Mass Storage Device doesn't work.

Here you go: Hello. VSOS 3.58 build Jun 04 2020 11:41:03 VLSI Solution Oy 2012-2019 - www.vlsi.fi Starting the kernel.. Starting Devices... External SPI Flash Installed system devices: S: SPI Flash bf41. E'Device not open' 0 driver(s) loaded. VSOS running with 5 tasks: Task I/O Stack:0010-020f (512w...
by FelixKunzJr
Mon 2020-06-08 10:35
Forum: VS1005 and VSOS Software
Topic: USB Mass Storage Device doesn't work.
Replies: 16
Views: 2362

Re: USB Mass Storage Device doesn't work.

I flashed your kernel successfully, but the behaviour is still the same. The prommer message: Default SPI speed 0.5 Mbit/s Serial Flash RDID: manufacturer bf, type 25, density 41 Serial Flash REMS: bf41 Opened map file "eeprom_e.map" Programming file "eeprom.img" (0x009a0a bytes) to addr 0x000000 (0...
by FelixKunzJr
Tue 2020-06-02 15:29
Forum: VS1005 and VSOS Software
Topic: USB Mass Storage Device doesn't work.
Replies: 16
Views: 2362

Re: USB Mass Storage Device doesn't work.

I could solve many problems by now. Indeed, i have a VS1005G without internal flash. This explains a lot. I've added an SST25VF016B SPI flash, and flashed it with the prommer from vside. I now have the Kernel 3.50. During the Flash prommer process i got a small error about "auto increment", but i th...
by FelixKunzJr
Thu 2020-05-28 18:24
Forum: VS1005 and VSOS Software
Topic: USB Mass Storage Device doesn't work.
Replies: 16
Views: 2362

Re: USB Mass Storage Device doesn't work.

Yes FVDD is connected to IOVDD. I have to correct myself, it seems like the VSPROM9 didn't do it's thing. It doesn't even show a flash/memory. Upon further investigation i found out, that my VS1005 doesn't seem to have an internal flash, which i assumed it had. So i hooked up an 25LC640 Eeprom to th...
by FelixKunzJr
Thu 2020-05-28 13:11
Forum: VS1005 and VSOS Software
Topic: USB Mass Storage Device doesn't work.
Replies: 16
Views: 2362

Re: USB Mass Storage Device doesn't work.

Did it, and it seems like it worked... but now when i want to flash a new kernel i get following error: Starting VS1005g internal SPI Flash prommer v2016-11-03... Default SPI speed 39.9 Mbit/s Serial Flash RDID: manufacturer 0 (C2), type 0 (20), density 0 (14) Bad RDID, quitting Failed in 0.71 secon...
by FelixKunzJr
Tue 2020-05-26 18:29
Forum: VS1005 and VSOS Software
Topic: USB Mass Storage Device doesn't work.
Replies: 16
Views: 2362

Re: USB Mass Storage Device doesn't work.

I have a VS1005G. There is also the number "8171720" and "1902" printed on top.

Sadly i don't get any message on the UART line. This made me suspicious, if the chip is working or not. But it shows up as an USB-Audio device, so it can't be all broken.
by FelixKunzJr
Mon 2020-05-25 14:26
Forum: VS1005 and VSOS Software
Topic: USB Mass Storage Device doesn't work.
Replies: 16
Views: 2362

USB Mass Storage Device doesn't work.

Hi, I just got the PCB i've designed for the VS1005. Naturally i soldered it together and wanted to give it a try. The first thing i tried is to connect the VS1005 to my computer in order to load libraries to the internal flash. I made sure GPIO0_6 is low, so the Chip should show as Mass storage dev...
by FelixKunzJr
Mon 2020-04-06 14:13
Forum: VS1005 and VSOS Software
Topic: Flash from SD Card
Replies: 2
Views: 1956

Re: Flash from SD Card

I got many things working now. I've edited the config.txt, so the VS1005 will mount the SD at start, and start the shell (similar to what is default when Button S2 is pressed during Boot). Then i've programmed an Atmega16 MCU in a way, that it will send commands like "PlayFile xxx" to the VS1005. Al...