Search found 94 matches

by HeLiO
Fri 2011-05-06 19:52
Forum: System Software
Topic: InitAudio() problem
Replies: 12
Views: 8017

Re: InitAudio() problem

The idea is not in UART debugging with overlays but in UART programming the SPI FLASH in 64 kb for example. I load 3000 words of code in SPI EPROM and then using overlays take them to code memory of vs1000b when needed.. this is the idea i meant
by HeLiO
Thu 2011-05-05 15:42
Forum: System Software
Topic: InitAudio() problem
Replies: 12
Views: 8017

Re: InitAudio() problem

Tnx , problem is in img file really.. Constants take ~ 200 words so thats why i havent enough space to hold all the code. By the way, is it possible to do overlays using OWN developers board (simply RS 232 + VS1000b) with uart programming..? If the answer is positive, where i can see the variants of...
by HeLiO
Thu 2011-05-05 13:27
Forum: System Software
Topic: InitAudio() problem
Replies: 12
Views: 8017

Re: InitAudio() problem

Tnx for answer. Still have the problems with UART but ill try to progtam GPS to send messages not so fast.. think it will solve the problem.
And you forgot to read the first problem i think.. about EEPROM

Tnx, Peter
by HeLiO
Wed 2011-05-04 17:02
Forum: System Software
Topic: InitAudio() problem
Replies: 12
Views: 8017

Re: InitAudio() problem

And another problem - different one and the same global as previous. I have GPS module installed via UART, and i get and parse NMEA messages from it. BAUD rate is 4800. I dont use UART interrrupt cause it gets stucked every time on 20-30 sec of working, so i monitor UART status in MyIdleHook all the...
by HeLiO
Wed 2011-05-04 10:32
Forum: System Software
Topic: InitAudio() problem
Replies: 12
Views: 8017

Re: InitAudio() problem

Just figured out some interesting thing. when i exlude from my project abour 1/4 of code, eeprom programs well and program started on VS1000b.. Very strange, i have 25LC640 eeprom 64 kbit and it seems not to have enough space to hold all my code memory while(!) compilator (via build source.c) says i...
by HeLiO
Wed 2011-05-04 10:07
Forum: System Software
Topic: InitAudio() problem
Replies: 12
Views: 8017

Re: InitAudio() problem

still waiting for support answer... tnx
by HeLiO
Tue 2011-05-03 13:14
Forum: System Software
Topic: InitAudio() problem
Replies: 12
Views: 8017

InitAudio() problem

Hi! When i try to load code ti EEPROM lc_25640 to boot wit hit further, everything goes ok and programs runs good (playing files from sdhc card). When i try to use UART , i put obligotary function : InitAudio(); /* goto 3.0x..4.0x */ as shown in yr example, and since that moment sudddenly problems s...
by HeLiO
Wed 2011-04-27 22:32
Forum: System Software
Topic: SDHC CARD WITH OGG FILES
Replies: 19
Views: 6961

Re: SDHC CARD WITH OGG FILES

1 more question: you have function OpenFileNamed("\p#3 " ,FAT_MKID('O','G','G')); (example calling).
I need to form name of file manually symbol by symbol. How i can do it, if you have first argument CONST u_int16 *fname ? it would be nive if you answer this week, tnx
by HeLiO
Mon 2011-04-25 20:08
Forum: System Software
Topic: SDHC CARD WITH OGG FILES
Replies: 19
Views: 6961

Re: SDHC CARD WITH OGG FILES

Yes i do but itry to control its execution by flags.. or its a wrong way..? The matter is in the fact that i need to have global function that will work during all the time VS is power upped, and in this function after complicated computations i need either to play file or to finish in corresponding...
by HeLiO
Mon 2011-04-25 17:53
Forum: System Software
Topic: SDHC CARD WITH OGG FILES
Replies: 19
Views: 6961

Re: SDHC CARD WITH OGG FILES

Problem solved partly - i tried to open file by name instead using ''open by number' variant - all went ok. But.. Im stuck again, and now problem isnt on the surface. I try to open the same file again each time it plays about 20 sec with puts an puthex fucntion as debug and with myidlehook, in which...