Page 1 of 1

VSMD001 module and slow USB Response

Posted: Tue 2018-07-10 15:41
by picdev
I work arround with the VSMD001 and the default firmware (0.72) it works as expected but it takes some time to apear as external usb drive.
I have tested in 5 pc with windows 10, all of them have i3 and 4gb ram at least.
Only In 1 pc its fast, but in most cases windows take some time to recognize it as external drive on "my computer"/This pc", and some extra time to read for first time the files. Is this something usual ?

Re: VSMD001 module and slow USB Response

Posted: Wed 2018-07-11 10:37
by pasi
Does the disk appear more quickly if uSD card is inserted?

Have you formatted the SPI FLASH disk on the PC? The default disk image on the SPI FLASH is not quite a valid FAT image. (It should be FAT12 for a disk of that size, but it isn't.)

Re: VSMD001 module and slow USB Response

Posted: Wed 2018-07-11 10:43
by picdev
I use a micro SD card 8gb , with FAT32 formated on windows 10.
If I use the module with internal 16mb flash , I have the same behavior.
I can format the sd card at FAT12 or fat16? or do you recommencement an allocation unit size ?

Re: VSMD001 module and slow USB Response

Posted: Wed 2018-07-11 12:03
by picdev
I make some tests with san disk HC1 16gb micro sd card.
I formated as fat16 with 4gb and it takes 24 seconds to read the files.
I formated as fat32 with 16gb and it takes 35 seconds

Re: VSMD001 module and slow USB Response

Posted: Wed 2018-07-11 12:56
by picdev
ok some update info, I make some tests with a sandisk micro sd CARD ( some previews tests was with a no name sd card :roll: )
In some PCs I see the files immediately and in others I must wait for 25 seconds.
With the san disk in 5 PCs only 2 have the slow response problem.
The storage drivers are the same,
I doesnt matter if its fat32 or fat16, In PCs with problem it takes more time for fat32, but in PCs with no problem I see the files immediately even the format is fat32.
I will try other brands or models, do you have a recommendation ?

Re: VSMD001 module and slow USB Response

Posted: Wed 2018-07-11 14:55
by picdev
Here are some screens from the windows event log, I see paging error.
Maybe is a drivers error because the pc runs windows 10 with generic chipset drivers ?
Only vlsi have this error , other usb flash drivers, or when I put the sd card on usb with adapter it works fine

Re: VSMD001 module and slow USB Response

Posted: Wed 2018-07-11 15:25
by pasi
picdev wrote:
Wed 2018-07-11 10:43
I can format the sd card at FAT12 or fat16?
The comment only applied to the internal SPI FLASH. SD cards are pretty much always large enough to be FAT32.

There may be some interactions if there are other USB devices on the same USB bus. Some machines may have internal card readers that appear in the same USB bus regardless of what you have connected. (The physical connections may not correspond to devices getting their own USB bus or not, so it's hard to say whether this might be the case.)

The VS1000 communicates with SD using the SPI communication mode. SD cards do not always respond as quickly as you would expect, which might cause timeouts for the USB-SCSI protocol, and potentially USB bus resets (and re-enumeration). Timeouts and bus resets happen regularly when using the SPI FLASH disk (and not a SD card).

Being a uSD card reader is not the primary function of the VS1000 Audio Module though.

Re: VSMD001 module and slow USB Response

Posted: Wed 2018-07-11 15:33
by picdev
the strange is that the problem exist on 2 PCs of 5 pcs.
The vlsi is not a card reader but I read the datasheet and says that is recognized from a PC as an external usb drive.
So we design a product that customers can add easy wav files on sd CARD.
We have design another PCB with a vlsi IC and a sd card reader that is connected on the MCU, but we chose this module for usb mass storage support