Page 1 of 1

VSMD001 - basic problem

Posted: Tue 2019-08-06 11:14
by ZmagoJ
Hello,

We are trying to implement your audio module VSMD001 to our product, but experience difficulties:

Connection through USB works fine and we were able to upload audio filles additionally to the ones already in FLASH.
Connecting UART (no USB) and 5V power supply (3,3V RX/TX), the module sends: "v0.72-uart Macronix 2MB" and seems to be working
The default firmware is according to manual supposed to start with autoplay, but nothing happens.
After pulling reset pin down, it again sends the firmware version as above.
Sending commands over UART doesn't seem to make any difference.

On one singular attempt the module started to send UART messages for playing, but cud not be repeated again. We also tried to use single LiPo for a more stable power, but with no success.

Can you please guide us to find a solution. We need a demo design ASAP.
Thanks.

Re: VSMD001 - basic problem

Posted: Tue 2019-08-06 13:49
by pasi
Hi,
I suggest you try to reformat the disk with PC, then copy files. (The original disk content is not strictly a valid FAT12 filesystem, so PC and the module do not agree on how to access it.)

Have you tested playing from a uSD card?

Also see: viewtopic.php?f=8&t=461

Re: VSMD001 - basic problem

Posted: Sun 2019-08-11 12:04
by ZmagoJ
Hello,

In the meantime we ordered another sample that works OK from the box, plays default soundtracks and responds to commands.
After connecting to USB and downloading additional track it doesn't and stops responding. It only sends its welcome text at bootup.

We also tried with FAT format (the default one proposed in win10), but with no effect.
Can you please advise how to continue.

We will also try with SD card, but it is not intended to be used in a product.

Re: VSMD001 - basic problem

Posted: Sun 2019-08-11 20:33
by ZmagoJ
hello again

We tried some additional things.
1. What is the right way to format the drive to FAT12?
We formatted using windows (FAT12) - stil no change
Tried to format flash using your tool "VS1000B formatter generator" - VS1000_B.RUN file , by copying the file to flash and pulling out USB comm wires - it seems it does nothing as we also tried to change storage volume.
2.tried playing from SD card with no success
3. tried to upload play file through SD card (SDUPDATE.PRG and CONTENT.RAW file)

It is the new board we ordered after failing with the first one. out of the box it worked, and responded to UART commands, but after uploading file to flash through USB it is the same as first one (WAV file).
It sends the initial info at boot, but doesn't respond to anything afterwards. USB storage works fine if we plug it in.

Please advice, we are running out of ideas.

Re: VSMD001 - basic problem

Posted: Fri 2019-08-16 0:03
by ZmagoJ
Any Idea yet?

Re: VSMD001 - basic problem

Posted: Fri 2019-08-16 12:27
by Panu
Hi!

Oh, hmm, Pasi, who has written the VS1000 software, is on holiday for a couple of weeks.. not sure if anything meaningful can be achieved before he comes back :(

In the mean time, you can try to best build an idea of how the unit behaves - is is possible for you to revert the unit into a working state by reprogramming the flash with the VLSI original firmware? And which firmware gives the best results? And does it always fail the same way?

Also, have you tried to use an older OS such as Win7 or even earlier windows? Maybe there is a difference? If there is a difference, it would be interesting to know.. maybe it has something to do with subdirectories that Win10 creates to hold its indexer guid and other info on the disk in a hidden subdirectory.

-Panu

Re: VSMD001 - basic problem

Posted: Mon 2019-08-19 19:50
by ZmagoJ
Hello,

After reflasing firmware it works again.
It seems that win10 really does something your code can not digest.
Havent tried Win7.