Corrupt Oggs

Writing software for systems that use VLSI Solution's devices as slave codecs to a host microcontroller.
Post Reply
quickshat
User
Posts: 14
Joined: Fri 2016-07-22 11:21

Corrupt Oggs

Post by quickshat » Mon 2019-06-17 18:00

Hi,

OGG encoder works nearly fine by now BUT there is an approx. 33% chance a record leads to a complete corrupt file. These corrupt files have many similarities and can't be decoded of course.

I'm gonna attach one of these below, maybe you can see whats going wrong.
The device has a patch applied before any recording!

When the record goes well (3 seconds), the resulting file is 9kB of size - when corrupt its approx. 1kB.
corrupt.ogg
(1.35 KiB) Downloaded 12 times
Best Regards!

User avatar
pasi
VLSI Staff
Posts: 1580
Joined: Thu 2010-07-15 16:04

Re: Corrupt Oggs

Post by pasi » Thu 2019-06-20 16:24

What is the CVDD voltage and the value of CLOCKF you are using?

Check that the vs1063a RX pin isn't floating, because it could cause a jump to a ROM monitor in the middle of the encoding.

Also see that the xTEST pin is pulled high or connected to IOVDD.
Visit https://www.facebook.com/VLSISolution VLSI Solution on Facebook

quickshat
User
Posts: 14
Joined: Fri 2016-07-22 11:21

Re: Corrupt Oggs

Post by quickshat » Fri 2019-06-21 11:59

Hi,

CVDD is 1.8V+ , CLOCKF Value is : 0xC000 but only during recording - when in decoding mode: 0x6000.
You said 1063a but we have a 1053b. RX in this case is floating.

XTest is driven high with 3.0V+.

Regards

User avatar
pasi
VLSI Staff
Posts: 1580
Joined: Thu 2010-07-15 16:04

Re: Corrupt Oggs

Post by pasi » Mon 2019-06-24 17:18

Pull up RX, or as an easy workaround connect it to TX.

If that doesn't help, perhaps there is something wrong in the application upload to vs1053b. You might try slowing down the code upload and see if that helps.

Also check that GPIO0 and GPIO1 are pulled low, to prevent vs1053b from entering real-time MIDI mode.
Visit https://www.facebook.com/VLSISolution VLSI Solution on Facebook

quickshat
User
Posts: 14
Joined: Fri 2016-07-22 11:21

Re: Corrupt Oggs

Post by quickshat » Tue 2019-06-25 18:38

Thanks for your support!

I will try these things out and keep you updated here.

Regards,
quickshat

Post Reply