Page 1 of 1

INITNAND gets stuck

Posted: Sat 2018-02-03 19:43
by YuryShatz
Hello there.

Please help, this is so frustrating.

I connected NAND module S34ML04G200TFI000 (http://www.cypress.com/file/218306/download) to the breakout board, according to the datasheets and to the dev board schematics.

Removed all the other devices, other than UART. Pulled up NAND CE, because datasheet says it should by UP during boot. Pulled up NAND WP.
Powered NAND from IOVDD.

When I run INITNAND.BAT, it displays these lines and then hangs. There is no more output.

VSEMU 2.2 Nov 12 2010 16:48:42(c)1995-2010 VLSI Solution Oy
Using serial port 3, COM speed 115200
Waiting for a connection to the board...

Caused interrupt
Chip version "1005"
Stack pointer 0x3e0, bpTable 0x92e8
User program entry address 0x9128
nandprog-vs1005g.bin: includes optional header, 16 sections,
Section 1: startup page:0 start:128 size:9 relocs:4 fixe
Section 2: puthex page:0 start:137 size:52 relocs:2
Section 3: fputhex6 page:0 start:189 size:63 relocs:2
Section 4: puthex6 page:0 start:252 size:19 relocs:1
Section 5: GetParam page:0 start:271 size:94 relocs:21
Section 6: PrintSector page:0 start:365 size:65 relocs:14
Section 7: NandGetIdent page:0 start:430 size:109 relocs:24
Section 8: main page:0 start:539 size:442 relocs:141
Section 9: bss_x page:1 start:2304 size:5864 relocs:0
Section 10: const_y page:2 start:1280 size:17 relocs:0
Section 11: const_x page:1 start:8168 size:333 relocs:0
Section 12: VS_stdiolib page:0 start:981 size:110 relocs:32
Section 13: VS_stdiolib$0 page:0 start:1091 size:24 relocs:
Section 14: FPutc page:0 start:1115 size:15 relocs:1
Section 15: fprintf page:0 start:1130 size:23 relocs:2
Section 16: printf page:0 start:1153 size:23 relocs:2
---

I am attaching connection schematics.

Can anyone advice what I am doing wrong? Did I forget some PIN? Should I pull something else up or down? Does anything on breakout board orevent it from working?
Is there any way to diagnose this?

Thanks in advance

Re: INITNAND gets stuck

Posted: Mon 2018-02-05 9:25
by Panu
How's your NFRDY signal? If Chip Select is high and Ready is low, the hardware gets stuck waiting for the nand flash to become ready.

-Panu

Re: INITNAND gets stuck

Posted: Mon 2018-02-05 17:49
by YuryShatz
(removed. Solution found!)

Re: INITNAND gets stuck

Posted: Mon 2018-02-05 18:04
by YuryShatz
(removed. Solution found!)

Re: INITNAND gets stuck

Posted: Mon 2018-02-05 22:41
by YuryShatz
(removed. Solution found!)

Re: INITNAND gets stuck

Posted: Mon 2018-02-05 23:09
by YuryShatz
For anyone reading this:

Removed my program and all the drivers, rebooted. InitNAND works like a charm.

It may or may not be obvious.

Re: INITNAND gets stuck

Posted: Tue 2018-02-06 0:32
by YuryShatz
(deleted, solved another problem myself)

Dear Panu

Sorry about bothering you with the problems I can solve myself.

Recap in case someone else is wondering:
After successfully running InitNAND you need to format NAND.
The solution is here: viewtopic.php?f=13&t=1664&p=8213&hilit= ... nand#p8213.

1) put K9F4G S in section [5] of config.txt (it seems important that the drive letter is S!)
2) Boot board with high GPIO0_0 and GPIO0_1.

Thanks again.