Page 1 of 1

VS1005 Rec - problem solving

Posted: Mon 2022-06-13 13:21
by Henrik

This is a continuation from the thread
to answer Rec-related questions by Arkantium.
1) When maximum size file is limited or "n" case is pressed, it stops recording and prepare a new file incrementing the number of file, but it never continues recording, and, if the sistem is restarted, it starts as "0" again.
This may happen if the file system on your SD card is in inconsistent state. I recommend you format the drive:

Code: Select all

S:>format d:
You will lose all your data on your SD card when you format!

This should solve your issue. If lockups continue, let us know.
2) Is there any way to make it work using the pins as you told us for the HiResRec?
Rec doesn't have built-in GPIO controls. However, it is possible to add GPIO functionality at the location of Rec solution file main.c, around the source code line 763 which states "switch(c)". The full source code for the application is available in the package, available at the end of the thread:

If you can customize the C source code by yourself, that would perhaps be the most convenient way because then you can also modify functioanlity. However, if this is a problem, we can help.

Kind regards,
- Henrik

Re: VS1005 Rec - problem solving

Posted: Mon 2022-06-13 14:36
by Arkantium
Good afternoon Henrik,

I have tried to format the SD card using "S:>format d:", and that is the result:

S:>format d:
Raw disk geometry: 15286272 sectors (7464 MiB = 7.3 GiB), 1 sect per block
sectors 15286272, sectorsPerCluster 16, clusters 954880
numberOfFats 1, sectorsPerFat 7461, reservedSectors 731
startOfFat 0, startOfFileSystem startOfFat+8192
serialID 0xffffc447
Are you sure you want to format drive D:? All data will be lost! (Y/N)
Writing FAT32 information (4.0 MiB of data)...
Formatted capacity: 15278080 sectors (7460 MiB = 7.3 GiB)
E'SD not found'
E'Retry with 1-bit mode'
E'SD not found'

After that, I tried to just format from the laptop and once done correctly, I inserted it into the board again and the same problem persists, it stops recording and never continues. And even If I try to format again using the method you told me, same text appears again.

Regarding to the pins control, we are not software experts, so we would appreciate any help or template to unless start with.

As a resume we just need to start recording when power on or with a button and stops the same way, with a button or just powering off. It seems simple but we are getting stuck there.

At the moment we are even using "RunProgram" from inside the code, but we are not getting the result we need.

We appreciate any help.

Many thanks.

Kind regards.

Re: VS1005 Rec - problem solving

Posted: Tue 2022-06-14 6:40
by Henrik
Hello Arkantium!

Thanks for the dump from the format command. They are always helpful!

The "SD not found" message appears very odd to me. It makes me suspect something may be going wrong on the hardware level.

I'll have to think a bit and see if I have further questions.

Kind regards,
- Henrik