Battery Boost Ruining VS1010

Designing hardware and software for systems that use the VS1010 MP3 Audio DSP Microcontroller.
Post Reply
Haden98
User
Posts: 5
Joined: Mon 2022-01-24 20:44

Battery Boost Ruining VS1010

Post by Haden98 »

Hello,
I'm currently working on a design using a Microcontroller and the VS1010. On the board I have VIN(4.2V) to the board supplied to a a 3.3 volt regulator which powers a microcontroller. When the Microcontroller receives a command, it turns on a power switch IC which then switches VHIGH(4.2V) on to the VS1010 to power it. When VIN is supplied by a DC power supply or through a micro-USB port (here VHIGH = 5V) the board works fine. I am able to receive characters to a terminal on my computer through UART from the VS1010, which indicates that the board is working.

However, when I use a boost converter to power the board, the moment it turns on, the VS1010 stops working and never prints any characters to a terminal on my pc to show that it is executing any code, or is working. When power cycling and changing my power source back to DC supply the VS1010 doesn't print anything to the terminal. However the 3V3 regulator continues working, and my microcontroller doesn't have any issues. Does anyone have any solution as to what could be causing a boost converter to ruin the VS1010, or any advice about how to successfully power a VS1010 via a battery and boost converter?

I am using a Pololu boost converter (pololu.com/product/2868, s9v11macma) and a tck106af,lf switch
Hannu
Senior User
Posts: 396
Joined: Mon 2016-05-30 11:54
Location: Finland
Contact:

Re: Battery Boost Ruining VS1010

Post by Hannu »

So you boost VIN? First question is that do you have to boost it.

VS1010 can live with AVDD + 0.3 V giving 3.9V. And if you want to go little bit lower it is possible by small piece of software. And when USB is connected, 5V can come from there.

To debug more measure the CVDD, AVDD, and AVDD. Also how the XRESET pin is connected? Does the behaviour change if you keep PWRBTN high when you enable the booster?

If you play (play R:hello.mp3 is always available) something and then enable the power does the clock signal from MCLK pin disappear?

Do you have oscilloscope? Measure the VHIGH from the VS1010 pin.
Post Reply