VSIDE v2.38 Build failed help

Installing and using VSIDE tools for VLSI Solution's devices that contain a VSDSP signal processor.
Post Reply
seulater
User
Posts: 10
Joined: Thu 2015-03-26 17:09

VSIDE v2.38 Build failed help

Post by seulater »

I just installed VSIDE v2.38. I clicked New-> Project/Solution, VS1000 Project, then VS1000 Hello World.
I then clicked Build Solution and I get the following in the Build Output window.

Code: Select all

Build started. Project: MyProject, configuration: Emulation-Debug

lcc -g -hhw_desc -O6 -fsmall-code -DDEBUG -Iinclude -IC:\Program\ Files\ (x86)\VSIDE\libvs1000 -o Emulation-Debug\main.o C:\Users\Jim\Documents\solutions\MySolution7\main.c
C:\Users\Jim\AppData\Local\Temp\make98122.sh: line 1: syntax error near unexpected token `(x'
C:\Users\Jim\AppData\Local\Temp\make98122.sh: line 1: `lcc -g -hhw_desc -O6 -fsmall-code -DDEBUG -Iinclude -IC:\Program\ Files\ (x86)\VSIDE\libvs1000 -o Emulation-Debug\main.o C:\Users\Jim\Documents\solutions\MySolution7\main.c'
C:\Program Files (x86)\VSIDE\bin\make.exe: *** [Emulation-Debug\main.o] Error 258


Build failed!
I then tried many different Solution and projects and everything I have opened gives a Build Failed result. Any ideas ???
User avatar
Panu
VSDSP Expert
Posts: 2816
Joined: Tue 2010-06-22 13:43

Re: VSIDE v2.38 Build failed help

Post by Panu »

Hi!

Yeah, I know this problem.. It's weird because it only happens quite rarely, e.g. in only some computers and we haven't been able to reproduce it in our build environment. I'm not sure if it's due to some other version of Make installed by some other software, or due to localization or OS language options or what, but there is fortunately a simple fix... The problem is the " (x86)" in "Program Files (x86)" of VSIDE installation path. The simple fix is to reinstall VSIDE into C:\VSIDE to get rid of the special characters in the file names.

Sorry about your trouble!!

-Panu
seulater
User
Posts: 10
Joined: Thu 2015-03-26 17:09

Re: VSIDE v2.38 Build failed help

Post by seulater »

Thank you. That did fix it.
FWIW, I did have another application that had make installed.
Post Reply