Page 1 of 1

Trouble Building New VS1005 Kernal

Posted: Thu 2016-06-23 0:06
by Mark

I am in the process of building an updated kernel for the VS1005 BOB. I have downloaded the latest version of the VSIDE, am running as administrator, and started a new project as follows:

- File, New, Project/Solution
- VS1005 Solution
- VSOS Kernal 3.26 for VS1005G Internal or External Flash

I have attached the error log -
VSIDE VSOS326 Compile Log .txt
(20.22 KiB) Downloaded 170 times
I think that this issue may be already answered in this topic, but want to make sure that it is the same issue. FYI, the computer is a Win7 PRO OS and it does have a number of other IDE's installed (MPLAB, Netburner, Visual Studio, etc).


Thank You,

Re: Trouble Building New VS1005 Kernal

Posted: Thu 2016-06-23 9:05
by Panu

1. Kudos for using the word 'Kernal'! ;) We love Commodore too!

2. Yeah, it's strange why this sometimes happens. Maybe you need administrator privileges for the VSIDE. Or maybe another program (MPLAB IDE?) is interfering with VSIDE's Make? Anyway, there's an easy remedy; remove the Copy lines from Project -> Properties -> Pre/Post Build:
copycmd.png (54.49 KiB) Viewed 2573 times
That will solve the issue and normal users don't need these commands. They're only needed when you make changes to the OS interface.


PS. Hmm, could you try something before you remove the copy lines? I still worry that VSIDE might have ended up using Make from some other vendor's IDE. Can you disable them temporarily (rename any directories that have other microcontroller development tools) one by one and see if that makes the problem go away? Everybody would be very happy if someone could find the exact cause.

Re: Trouble Building New VS1005 Kernal

Posted: Thu 2018-03-08 17:16
by mar_tin

I just got this error today an so far nothing seems to be working. Funny thing is that two days ago the build was woking, I just didn't have a 1005 DevBoard yet. Board arrived yesterday, but now I 'm stuck with preinstalled 3.42 software.
(21.48 KiB) Downloaded 73 times
Everything I have done from the beginning:

1) Two days ago I have installed the VSIDE 2.43 to C:\VLSI\VSIDE. Tried creating some 3.50 Solutions for 1005 and VSOS3 as described in the video tutorial. Everything worked OK, build has finished, just didn't have the hardware to try it on.

2) Tried messing around with VS1010 Solutions, just searched what kind of code is in the IDE.

3) Today I started by manually deleting all testing solutions which I created.

4) Meanwhile the antivirus has also updated itself with awesome CyberCapture feature enabled, which stops and checks every file being executed for possible problems. It releases it after 10secs or so. Finally I disabled this awesomeness, because it was causing the buld process to hang. Thought that might be the problem, but it did not help.

5) Uninstalled and reinstalled the VSIDE to C:\VSIDE. No change.

6) Found this thread and tried to remove the two COPY commands. Another errors and warnings, but still unable to build successfully.
(3.42 KiB) Downloaded 75 times
Even tried running as admin.

7) Uninstalled the IDE again, also removing the registry keys HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\VSIDE and HKEY_CURRENT_USER\Software\VLSI Solution, even restarted afterwards.

8) Installed the VSIDE again, still the same problem while trying to build the "VSOS3 version 3.50 kernel for VS1005G and Internal SPI Flash." (but tried the external too)

9) Downloaded and tried to the VSOS_354g_IntFlash, the same error.

My computer is equipped with lot of MCU IDEs (Arduino, Atmel Studio, CooCox IDE, Eclipse - native, ESP32, IQRF, Keil uVision for ARM, SiLabs Simplicity Studio, SW4STM32, and others), so thinking of trying to rename all of them gives me a headache.

Don't know if I have missed something or what should I try next.. Any help appreciated!

And btw, Windows 7 Pro 64bit.

Re: Trouble Building New VS1005 Kernal

Posted: Fri 2018-03-09 9:48
by Panu

For some reason it seems that MS-Dos style commands (COPY, REM) are not found on your system. That's strange. Maybe you can find COPY.COM or COPY.EXE and place it in your C:\VSIDE\BIN directory.

Hmm, or maybe you can try to replace the copy command with xcopy - that at least seems to be a bona fide separate executable in windows.


Re: Trouble Building New VS1005 Kernal

Posted: Fri 2018-03-09 11:28
by mar_tin
So that's whats going on.. OK, I really did not find the copy and rem (searching the windows directory), strange that it must have been present a few days ago. I'll probably try to find them somewhere else.

Xcopy seems to work with

Code: Select all

xcopy eeprom_i.img eeprom.img /y
not with these two lines because of slashes/backslashes, so I removed them:

Code: Select all

rem xcopy vsos03.o "$(HOMEPATH_WIN)/libvs1005g" 
rem xcopy vsos03.o "$(HOMEPATH_WIN)/libvs1005g_vsos3" 
This line obviously does not work either:

Code: Select all

@rem $(IF_DEPLOY) xcopy kernel.sym $(TARGETDRIVE)\sys\kernel.sym /y
But at least I have now successfully flashed the eeprom.img to the internal flash using the prommer utility.

Panu, thank You for the support, Martin.

EDIT: if I open windows command line, the copy and rem seems to be responding.

Re: Trouble Building New VS1005 Kernal

Posted: Sat 2018-03-10 9:56
by Panu
Right... I've never seen this specific problem before..