Page 1 of 1

VSIDE 2.05, Usb-Serial Cable and VS1053 Hi-Fi Player

Posted: Tue 2010-08-17 8:49
by Madwhily
Hi,

Please help, using the VSIDE, VS1053b USB Hi-Fi Player and USB-Serial Controller Cable.

Last night I managed to download the driver for the USB-Serial Controller (pl-2303hx driver) PL2303_Prolific_DriverInstaller_v130.zip that seemed to get the USB-Serial cable working on COM3.

Next I created a new Solution/Project in VSIDE, I Changed the Port in VSDIE project setting (HW Emulation) to COM3, 9200, build the project then hit Debug (F5)… here is where trouble starts.

If the Hi-Fi Player’s LED is steady Green/ Switched on and Playing/Paused with SPI cable attached (T=Yellow,R=Green,+-) there is no communication from the Device to VSI Handshake Error.

I too tried the vskit134b (As instructed in manual 3.1-3.2.2) which also fails asking for Waiting for connection to device and gets no further.

UPDATE: Tried this morning to configure all on COM17 now if Hi-Fi Player is on and in Play state and I hit the F5 (Debug) button VSIDE Freezes completely!

Can you perhaps help in pointing me in the right direction, where am I going wrong.

Thanks

Will

Re: VSIDE 2.05, Usb-Serial Cable and VS1053 Hi-Fi Player

Posted: Fri 2010-08-20 8:53
by Panu
Hi!

First of all, remove the SD card when you attempt to connect. Install the boot prevention jumper (holes available on the side of the board near eeprom). That should enable you to connect. If not, there are other things you can do to make sure you can connect but let's think about them if necessary.

I suggest that you start with a vs1053_hifi_player template on VSIDE2.05. It should have all the settings ready for the HiFi player board.

Sincerely,
Panu

Re: VSIDE 2.05, Usb-Serial Cable and VS1053 Hi-Fi Player

Posted: Fri 2010-08-20 9:02
by Madwhily
Hi Panu,

Thanks, I have been getting assistance from Pasi.

Managed to solder new JP6 jumpers to the bord, note that there is no printed JP6 marker on the bord.
Also managed to download the USB-Serial Controller Drivers for from http://www.prolific.com.tw/eng/downloads.asp?id=31

I can now run my code from VSIDE on teh HiFi Player. (Note: the SD Card can remain in when connecting.)

The only other issue I have is I cannot Break into my code in Debug, at Run(F5) it tells me invalid breakpoints..?

Greets
Will

Re: VSIDE 2.05, Usb-Serial Cable and VS1053 Hi-Fi Player

Posted: Fri 2010-08-20 9:05
by Panu
Dear Will,

Yes, the HiFi player is diffucult to debug with the debugger. The normal code uses UART for other purposes. I'll see what I can do about it when I get back to Finland!

Greetings,
Panu

Re: VSIDE 2.05, Usb-Serial Cable and VS1053 Hi-Fi Player

Posted: Fri 2010-08-20 10:14
by Madwhily
Great thanks!
W