VS10xx Debug

Installing and using VSIDE tools for VLSI Solution's devices that contain a VSDSP signal processor.
Post Reply
Julian
User
Posts: 8
Joined: Thu 2010-08-26 23:49

VS10xx Debug

Post by Julian » Fri 2010-09-17 13:59

Further to my last posting, I cannot connect (communicate) to the VS10xx (1053 chip) V2.0 prototyping board from VSIDE. I am using a FTDI MM232R USB-serial module (http://www.ftdichip.com). It is configured for USB power and 3.3V signals. I have connected TX, RX and GND to the appropriate pins on JP1. When I monitor the TX signal from the MM232R (connected to RX, pin25) the voltage levels are correct and I see the (low) start pulse and a low at approximately bit 4 position. The timing appears correct for 9600 baud. After a short delay I see the same pattern, but at a higher baud rate. There is no activity on the RX pin (TX from the board, on pin23) - continually high. Sometimes VSIDE reports no communication and sometimes VSIDE hangs (not responding) and I have to shut it down. I have tested the MM232R on another system (directly connected to a NXP P89LPC935 micro-controller), checked the device driver, checked the serial port settings both on the PC and in the setup for the "solution " in VSIDE. I have also tried switching the board off and on again to cause a reset - all to no avail. The board works fine in stand-alone mode. What am I missing?

User avatar
pasi
VLSI Staff
Posts: 1596
Joined: Thu 2010-07-15 16:04

Re: VS10xx Debug

Post by pasi » Fri 2010-09-17 19:36

Julian wrote:What am I missing?
Have you tried removing the boot jumper AND the SD/MMC card?

If the card is inserted, GPIO1 will be high and GPIO0 low, and that combination starts the Real-Time MIDI mode. This mode receives MIDI commands from UART at 31250bps, thus no emulator connection.
Visit https://www.facebook.com/VLSISolution VLSI Solution on Facebook

Post Reply