(imggen052.exe) VSMD001 not playing after programming spi flash with wrong size

Writing software that controls the system and peripherals such as displays, SD cards, Buttons, LEDs, Serial Ports etc.
Post Reply
king2003
User
Posts: 5
Joined: Mon 2016-04-18 0:53

(imggen052.exe) VSMD001 not playing after programming spi flash with wrong size

Post by king2003 » Mon 2016-04-18 9:26

I've used imggen052.exe to create a personal CONTENT.RAW but in settings I set wrongly the size of the spi flash to 16mb instead of 2mb
and I flash it through µSD card (with SDUPDATE.PRG). I did not notice my wrong till I saw the module (VSMD001) not playing songs !!!
I tried several times to reflash it with both FIRMWARE.RAW (of downloaded VS1000AudioModule) and CONTENT.RAW (this times with size of 2MB) through µSD card without any success !!!
Can anyone help me to repair this module ?

User avatar
pasi
VLSI Staff
Posts: 1416
Joined: Thu 2010-07-15 16:04

Re: (imggen052.exe) VSMD001 not playing after programming spi flash with wrong size

Post by pasi » Mon 2016-04-18 13:08

Hi,

It sounds like an oversized content file overwrote the firmware at the beginning of the SPI FLASH.

You need to reprogram the firmware through the UART. (The programming using uSD card is not a ROM-firmware feature. It is part of the VS1000 Audio Module firmware that is preprogrammed into the module.)

You can use either VSIDE or the pcflash.exe ( http://www.vlsi.fi/en/support/software/vs1000tools.html ).

Note that the UART pins are logic-level and not RS232 level.
Visit https://www.facebook.com/VLSISolution VLSI Solution on Facebook

king2003
User
Posts: 5
Joined: Mon 2016-04-18 0:53

Re: (imggen052.exe) VSMD001 not playing after programming spi flash with wrong size

Post by king2003 » Tue 2016-04-19 16:38

pasi wrote:Hi,

It sounds like an oversized content file overwrote the firmware at the beginning of the SPI FLASH.

You need to reprogram the firmware through the UART. (The programming using uSD card is not a ROM-firmware feature. It is part of the VS1000 Audio Module firmware that is preprogrammed into the module.)

You can use either VSIDE or the pcflash.exe ( http://www.vlsi.fi/en/support/software/vs1000tools.html ).

Note that the UART pins are logic-level and not RS232 level.
Hello Pasi

Yes this is what happened, I overwrote the whole SPI FLASH including the firmware. The module cannot boot.
I used PCFLASH with a USB to TTL conveter (CP2102 module) to write the firwmare (spiall.spi).
Then I used µSD card to write CONTENT.RAW.
Now it is functionning properly. (I thought the module is dead)

Thanks Pasi for your advices.

Post Reply