VS1053+WAV PCM RECORDER: no amplification

Designing hardware that use VLSI Solution's devices as the system controller for the entire design.
User avatar
Henrik
VLSI Staff
Posts: 1271
Joined: Tue 2010-06-22 14:10

Re: VS1053+WAV PCM RECORDER: no amplification

Post by Henrik »

Hello!

I am the author of the VS1053 WAV PCM Recorder.

It's been a while since writing this piece of software, but Pasi is absolutely correct: contrary to what the documentation says, there is no volume control for the input. This feature is actually there on purpose: we have no freely adjustable analog gain, so to keep the utmost best audio quality, the software doesn't offer digital gain. The reason is that while digital gain may adjust the levels of the recording to more acceptable levels, it can never enhance the fidelity of a recording, only worsen it. To get an optimal high-quality recording, you should use a high-quality adjustable analog amplifier in front of the VS1053 inputs.

So, the documentation that SCI_AICTRL1 is a recording volume/gain control is incorrect. I am sorry by the confusion from the documentation, and I will correct the documentation and update it on our webpage soon.


Kind regards,
- Henrik
Good signatures never die. They just fade away.
SJS
Senior User
Posts: 22
Joined: Mon 2021-01-25 19:20

Re: VS1053+WAV PCM RECORDER: no amplification

Post by SJS »

Hello Henrik,

does this also affect the line input? I am designing an application where a stereo line input is used - i planned that volume/treble/bass control within the VS1053 is used. If that doesn't work, a $1000 order for prototyping pcb's is for the garbage can :-(

Thanks,
Stefan
User avatar
pasi
VLSI Staff
Posts: 1984
Joined: Thu 2010-07-15 16:04

Re: VS1053+WAV PCM RECORDER: no amplification

Post by pasi »

Is there a reason you wanted to use the WAV PCM Recorder app instead of the built-in encoding mode?

Also note that Treble and Bass controls are not available in the encoding mode (neither the encoded or monitoring output), only in the decoding mode (for the output).

So, what do you want to do exactly with the analog input signal? Maybe there is a patch or plugin that suit you better or could be adapted.
Visit https://www.facebook.com/VLSISolution VLSI Solution on Facebook
SJS
Senior User
Posts: 22
Joined: Mon 2021-01-25 19:20

Re: VS1053+WAV PCM RECORDER: no amplification

Post by SJS »

Hello pasi,

i have planned to use the line in for routing an external audio source (DAB Tuner e.g.) to the output while using the volume and tone control of the VS1053. The goal is to realize internet radio + external DAB tuner or another analog audio source with VS1053. Normally, line out connections are always fixed level, so volume control of the VS1053 is needed (and tone control if possible).

Does this not work?
snip_20220318141538.png
snip_20220318141538.png (63.41 KiB) Viewed 406 times
SJS
Senior User
Posts: 22
Joined: Mon 2021-01-25 19:20

Re: VS1053+WAV PCM RECORDER: no amplification

Post by SJS »

Can anyone confirm if line-in routing to the output is working (with or without volume/tone control)?

Thanks,
Stefan
User avatar
pasi
VLSI Staff
Posts: 1984
Joined: Thu 2010-07-15 16:04

Re: VS1053+WAV PCM RECORDER: no amplification

Post by pasi »

There are several apps/plugins for routing the analog input to output outside of the encoding mode. There is the ADMixer option in the vs1053b patches package, and there's also a separate AD Monitor app:

VS1053/VS8053 ADMon EQ
  • Plays ADC input(s) through DAC with bass and treble controls, or EarSpeaker.

https://www.vlsi.fi/en/support/software ... tions.html

Another possibility is the VS1053b / VS1063a Equalizer.
Visit https://www.facebook.com/VLSISolution VLSI Solution on Facebook
SJS
Senior User
Posts: 22
Joined: Mon 2021-01-25 19:20

Re: VS1053+WAV PCM RECORDER: no amplification

Post by SJS »

Thanks pasi,

this sounds good. The equalizer seems to be a standalone software, but the ADMixer patch should work together with the encoding mode software - is this correct?

Then my problem should be solved :-)

Thanks,
Stefan
zulunation
Senior User
Posts: 30
Joined: Mon 2012-02-06 23:04

Re: VS1053+WAV PCM RECORDER: no amplification

Post by zulunation »

SJS your picture is incorrect.
If you want to use LINE input mic amplifier will not be used.
So that route should look like this.
vlsi_route.jpg
vlsi_route.jpg (81.67 KiB) Viewed 350 times
SJS
Senior User
Posts: 22
Joined: Mon 2021-01-25 19:20

Re: VS1053+WAV PCM RECORDER: no amplification

Post by SJS »

Thanks, you are absolutely right - that was my mistake. Of course the mic amplifier is not used in this case.
zulunation
Senior User
Posts: 30
Joined: Mon 2012-02-06 23:04

Re: VS1053+WAV PCM RECORDER: no amplification

Post by zulunation »

Hello Henrik

Thanks for clearing information about the software gain in the plugin.
Now I am sure there is no bug in my firmware :)
Post Reply