VLSI1063 hangs during MP3 encoding

Writing software for systems that use VLSI Solution's devices as slave codecs to a host microcontroller.
User avatar
pasi
VLSI Staff
Posts: 1467
Joined: Thu 2010-07-15 16:04

Re: VLSI1063 hangs during MP3 encoding

Post by pasi » Thu 2018-01-18 11:19

Reading the register continuously does produce some interrupt load. If there are no (or not enough) words to read, your controller can perform some other task or delay.

It should not cause a lockup though.
Visit https://www.facebook.com/VLSISolution VLSI Solution on Facebook

lauba1
User
Posts: 17
Joined: Wed 2017-01-11 9:26

Re: VLSI1063 hangs during MP3 encoding

Post by lauba1 » Thu 2018-01-18 11:45

ok thanks for answer. During weekend I will put here the simple code with our test.

User avatar
Henrik
VLSI Staff
Posts: 1101
Joined: Tue 2010-06-22 14:10

Re: VLSI1063 hangs during MP3 encoding

Post by Henrik » Thu 2018-01-18 13:40

Hello!

If I remember correctly, we don't recommend banging on the SCI_RECWORDS (alias for SCI_HDAT1) more often than 1000 times per second. As Pasi said, doing that should not lock anything up, but we cannot guarantee correct function of VS1063.

Kind regards,
- Henrik
Good signatures never die. They just fade away.

KtroniX
User
Posts: 6
Joined: Tue 2017-01-31 12:44

Re: VLSI1063 hangs during MP3 encoding

Post by KtroniX » Fri 2018-06-08 8:38

Hello Guys from VLSI,

We still trying to find out the reason of random VLSI VS1063 core hanging. We prepared changed layout for 4 layers PCB, repleaced 3V3 DCDC to LDO just to avoid converter noise.

Even with improved EMC still time to time device hangs.
Measurement done with magnetic field probe under codec at distance 2cm.

Legend:
yellow - series double sided PCB
red - double sided PCB prototype
blue - 4 layer PCB prototype.

Could you suggest us procedure how to check if VLSI core works? We are asking buffer fill reg. but it seems to be hardware part of IC which works permanently.

Kindly Regards
Simon
Attachments
ldo.jpg
ldo.jpg (126.87 KiB) Viewed 26 times

User avatar
pasi
VLSI Staff
Posts: 1467
Joined: Thu 2010-07-15 16:04

Re: VLSI1063 hangs during MP3 encoding

Post by pasi » Fri 2018-06-08 11:56

I have two ideas to try to divide and conquer the issue.

1. Can you try 1.9V-2.0V CVDD? However, you already use lower than max clock, so this shouldn't change the situation.
2. Encode with the UART output enabled and don't read the data through SCI to see if the encoding still crashes. If a crash happens, the UART output probably stops.

Did you already compare to how it performs without the patches package?
Visit https://www.facebook.com/VLSISolution VLSI Solution on Facebook

Post Reply