VS1053 - Disabling audio passthrough during OGG recording

Writing software for systems that use VLSI Solution's devices as slave codecs to a host microcontroller.
Post Reply
nvillar
User
Posts: 2
Joined: Tue 2018-07-24 2:56

VS1053 - Disabling audio passthrough during OGG recording

Post by nvillar » Tue 2018-07-24 3:03

Hi,

When recording audio using the VS1053 Ogg Vorbis Encoder Application, recorded audio is passed through to the output speakers/headphones, presumably for monitoring purposes. This is great when using headphones, but causes feedback when using a microphone as input and speakers as output.

Is it possible to disable this functionality? Setting SCI_VOL to 255,255 disables the output, but also seems to turn off the recording level - so the recorded file is perfectly quiet.

Ideally, recording levels would be maintained as normal but the audio output during recording would be turned off.

Many thanks,

Nic

User avatar
pasi
VLSI Staff
Posts: 1497
Joined: Thu 2010-07-15 16:04

Re: VS1053 - Disabling audio passthrough during OGG recording

Post by pasi » Tue 2018-07-24 12:03

Have you tried SCI_VOL = 0xc0c0 ?

It will lower the volume to 'zero' but keeps the analog power on so the ADC keeps working.
Visit https://www.facebook.com/VLSISolution VLSI Solution on Facebook

nvillar
User
Posts: 2
Joined: Tue 2018-07-24 2:56

Re: VS1053 - Disabling audio passthrough during OGG recording

Post by nvillar » Tue 2018-07-24 19:03

That's exactly what I was looking for - many thanks!

Post Reply