VS1010 run levels 1, 2, 4 and 18 not working after SPI reformat

Designing hardware and software for systems that use the VS1010 MP3 Audio DSP Microcontroller.
Post Reply
keith_playable
User
Posts: 1
Joined: Thu 2021-09-23 14:24

VS1010 run levels 1, 2, 4 and 18 not working after SPI reformat

Post by keith_playable »

Hello, I'm working with a custom board that doesn't currently have an SD Card configuration, instead there are 256kbytes of SPI Flash and I used run level 4 to mount the SPI flash as a USB drive on Windows for uploading dlx files. I recently had to reformat the SPI Flash drive from Windows. I then copied back in the normal firmware folder structure and everything worked OK again. However, I cleared out the SPI of all files again so that the drive was empty. Now, when rebooting at run level 15 I get the following output in Tera Term:

Code: Select all

C#0d1d
VS1010D VSOS 4.20
Files:6. Buffers:3.
Runlevel 15
SPIF:3711, 256K
SD:No ID.E'Out Of Mem 0!'
If I reboot with XCS0 connected to ground I can drop to the shell and inspect the devices:

Code: Select all

D: SD/SD Card
F: SPI Flash 3711
I: STREAM
R: ROMDISK
S: SD/SD Card
Using the command "dir f:" I can see that there are 0 files found in SPI Flash, which is as I expect. So, I now attempt to reboot at run level 4, which would normally mount the SPI flash as a USB drive on my PC. Instead I get a similar output to run level 15:

Code: Select all

C#0d1d
VS1010D VSOS 4.20
Files:6. Buffers:3.
Runlevel 4
SPIF:3711, 256K
SD:No ID.E'Out Of Mem 0!'
reboot 1 gives the same 'out of mem' error and reboot 18 gives the following:

Code: Select all

C#
VS1010D VSOS 4.20
Files:6. Buffers:3.
Runlevel 18
SPIF:3711, 256K
SD:No ID.EE'Ò'
''¥P4V'
E''¥P4V'SÒTPÄ^_b5&'
VSOS 4.20
Files:6. Buffers:3.
VSOS 4.20
Files:6. Buffers:3.
DevNullWrite(1): PP
Is there a way I can resurrect the device in order to mount the SPI as a USB drive once again?

All the best,
Keith
Post Reply